Author Topic: 1978 invader 440 electrical issue  (Read 50 times)

0 Members and 1 Guest are viewing this topic.

Maisonm12

  • Newbie
  • *
  • Posts: 1
1978 invader 440 electrical issue
« on: October 03, 2019, 11:01:39 PM »
So I have a 1978 invader 440 and the headlight, kill switch, key, and tachometer doesn't work on it. Any ideas what it could be?

Interceptor398

  • Administrator
  • Hero Member
  • *****
  • Posts: 1354
Re: 1978 invader 440 electrical issue
« Reply #1 on: October 04, 2019, 06:58:31 AM »
Welcome to the sight!!  Check all the connections to make sure they are tight and clean would be a good place to start.  Easy stuff first.

gixxer6

  • Hero Member
  • *****
  • Posts: 1244
Re: 1978 invader 440 electrical issue
« Reply #2 on: October 04, 2019, 08:27:50 AM »
Welcome to the sight!!  Check all the connections to make sure they are tight and clean would be a good place to start.  Easy stuff first.

This is where I would start as well.  Start by taking a look at the grey connector that connects the wire harness to the engine. 

mswyka

  • Hero Member
  • *****
  • Posts: 1235
Re: 1978 invader 440 electrical issue
« Reply #3 on: October 04, 2019, 08:57:10 PM »
Ditto.  It is usually something simple.  We had one sled where the connector on the back of the key switch kept sliding off.  It looked like it was on, but it had slid forward far enough so that it wasn't making contact.  On another sled, the wires in the socket on the engine were not locked in.   So, when we tried to plug in the connector from the wiring harness it would push one or two of the spades out the other side of  the engine connector.  That one took a while to figure out.
Intruders:  1978, 1979 X2, 1980, 1981 Custom
Invaders:  1979 340, 1980 440, 1980 440 TOC Custom
Projects:  1981 Invader 440, 1979 Invader 340, 1980 Invader 340, 1979 Intruder 440, 1982 Intruder 440, 1980 Drifter 340 F/C...