Author Topic: 79 Invader Throttle Cable  (Read 1121 times)

0 Members and 1 Guest are viewing this topic.

bfish

  • Newbie
  • *
  • Posts: 10
79 Invader Throttle Cable
« on: February 03, 2022, 10:56:21 AM »
The rebuild of my 1979 Invader 440 has stalled and I'm in search of throttle cable. I would prefer to source a new one but will take a used one if I can find it. If anyone knows where I can source a reliable cable, please let me know.

There was also a thread a few years back of taking old cables to mower shops to have them rebuilt. How was this done?

Thank you in advance, M

Interceptor398

  • Administrator
  • Hero Member
  • *****
  • Posts: 2023
Re: 79 Invader Throttle Cable
« Reply #1 on: February 04, 2022, 08:19:10 AM »

bfish

  • Newbie
  • *
  • Posts: 10
Re: 79 Invader Throttle Cable
« Reply #2 on: February 04, 2022, 12:44:01 PM »
Thanx, M

Scott,t,o

  • Newbie
  • *
  • Posts: 2
Re: 79 Invader Throttle Cable
« Reply #3 on: April 11, 2022, 02:27:35 PM »
I was just wondering if you purchased that throttle cable, and how did it work? I am a new member. I just purchased supposedly 1982 for 40 invader. Manufacture date on the side says 1979.

Interceptor398

  • Administrator
  • Hero Member
  • *****
  • Posts: 2023
Re: 79 Invader Throttle Cable
« Reply #4 on: April 11, 2022, 09:32:50 PM »
Welcome to the site!!   Build date suggests 1980 sled.

Scott,t,o

  • Newbie
  • *
  • Posts: 2
Re: 79 Invader Throttle Cable
« Reply #5 on: April 12, 2022, 09:40:46 AM »
Thanks for the reply. I bought the sled about three weeks ago compression was good 135 on one cylinder 132 on another. Started to terret down and figured out why it wasn’t running. Vacuum line from pump to crank case it was disintegrating. And finding some parts not quite up to par. Looking for a throttle cable.

mswyka

  • Hero Member
  • *****
  • Posts: 1757
Re: 79 Invader Throttle Cable
« Reply #6 on: April 12, 2022, 06:54:24 PM »
Thanks for the reply. I bought the sled about three weeks ago compression was good 135 on one cylinder 132 on another. Started to terret down and figured out why it wasn’t running. Vacuum line from pump to crank case it was disintegrating. And finding some parts not quite up to par. Looking for a throttle cable.

Be sure to read through the following helpful thread:  "So you got a "new to you Kawasaki snowmobile" "

 http://kawasakitrax.com/kawiforum/index.php?board=14.0
Intruders:  1978, 1979, 1981 Custom (Pink)
Invaders:   1980 440
Projects:    1981 Invader 440, 1982 Intruder 440